advent-of-code/flake.nix
2024-04-16 10:19:31 -07:00

50 lines
1.1 KiB
Nix

{
description = "It's Adventing Time";
inputs.nixpkgs.url = "nixpkgs/nixos-unstable";
outputs = {
self,
nixpkgs,
}: let
inherit (nixpkgs) lib;
forSystems = f:
lib.genAttrs [
"x86_64-linux"
"aarch64-linux"
] (system: f nixpkgs.legacyPackages.${system});
in {
devShells = forSystems (
pkgs: {
default = pkgs.mkShell {
nativeBuildInputs = [
pkgs.clang-tools
(pkgs.sbcl.withPackages (p:
with p; [
alexandria
cl-ppcre
iterate
split-sequence
str
]))
(pkgs.ghc.withPackages (p:
with p; [
containers
extra
regex-compat
split
text
text-icu
unordered-containers
vector
]))
];
CXXFLAGS = "-std=c++20 -Wall";
};
}
);
formatter = forSystems (pkgs: pkgs.alejandra);
};
}