dotfiles/modules/home/graphical/keepassxc.nix
eriedaberrie 83726a9df1 Initial commit
Note: not the actual initial commit.

I swear I will stop repeatedly force pushing to this single commit eventually
ok.
2024-09-28 00:10:52 -07:00

30 lines
722 B
Nix

{ pkgs, config, lib, ... }:
let
cfg = config.my.keepassxc;
in {
options.my.keepassxc = {
enable = lib.mkEnableOption null;
};
config = lib.mkIf cfg.enable {
home.packages = [ pkgs.keepassxc ];
systemd.user.services.keepassxc = {
Unit = {
Description = "KeePassXC password manager";
After = [ "graphical-session-pre.target" "tray.target" "eww-bar.service" ];
PartOf = [ "graphical-session.target" ];
Requires = [ "tray.target" ];
};
Service = {
ExecStart = "${pkgs.keepassxc}/bin/keepassxc";
Environment = "QT_QPA_PLATFORM=wayland";
};
Install = {
WantedBy = [ "graphical-session.target" ];
};
};
};
}