dotfiles/modules/os/cli/applications.nix
eriedaberrie 83726a9df1 Initial commit
Note: not the actual initial commit.

I swear I will stop repeatedly force pushing to this single commit eventually
ok.
2024-09-28 00:10:52 -07:00

45 lines
720 B
Nix

{ pkgs, config, lib, ... }:
let
cfg = config.my.cli.applications;
in {
options.my.cli.applications = {
enable = lib.mkEnableOption null // {
default = true;
};
};
config = lib.mkIf cfg.enable {
environment = {
systemPackages = with pkgs; [
vim
wget
gnumake
findutils
psmisc
file
file-rename
moreutils
pciutils
rlwrap
unzip
unar
bat
fd
ripgrep
eza
];
sessionVariables = {
EDITOR = lib.mkDefault "ex";
VISUAL = lib.mkDefault "vim";
};
};
programs = {
git.enable = true;
htop.enable = true;
};
};
}