dotfiles/modules/os/core/fs/ext4.nix
eriedaberrie 83726a9df1 Initial commit
Note: not the actual initial commit.

I swear I will stop repeatedly force pushing to this single commit eventually
ok.
2024-09-28 00:10:52 -07:00

16 lines
242 B
Nix

{ config, lib, ... }:
let
cfg = config.my.fs;
in {
config = lib.mkIf (cfg.type == "ext4") {
fileSystems = {
"/" = {
inherit (cfg) device;
fsType = "ext4";
options = [ "noatime" ];
};
};
};
}