dotfiles/modules/os/desktop/printing.nix
eriedaberrie 83726a9df1 Initial commit
Note: not the actual initial commit.

I swear I will stop repeatedly force pushing to this single commit eventually
ok.
2024-09-28 00:10:52 -07:00

25 lines
440 B
Nix

{ pkgs, config, lib, ... }:
let
cfg = config.my.desktop.printing;
in {
options.my.desktop.printing = {
enable = lib.mkEnableOption null;
};
config = lib.mkIf cfg.enable {
services = {
printing = {
enable = true;
cups-pdf.enable = true;
drivers = [ pkgs.gutenprint ];
};
avahi = {
enable = true;
nssmdns4 = true;
openFirewall = true;
};
};
};
}